Join The Community

v4.3 bug (Note: resolved with updates on issue)...

Please Note: This issues has been resolved via Tesla Service as of 3-16-2013...

After installing v4.3, my doors won't lock now (this has never happened before???) Earlier when it did this I called Tesla Customer Service, and they said to reboot the system (which solved it for an hour). Later, I walked out to my MS, and it was unlocked and my interior and door lights were on.

I notice that when I try and lock my doors with my fob, I hear the door handle motor, however, my door handles are not detracting, and remain unlocked.

Called Tesla Customer Service again, and they tried locking my doors remotely, and couldn't. I also couldn't do it via my iPhone with the Tesla App. It's like my MS now has a mind of it's own ;-0

The customer service rep said there wasn't anything else he could do from his end, so I will need to bring it in to my local service center for further evaluation.

Looks like I will have to ICE to work tomorrow, until I can get it into my service center :-(

Note to self: Don't download updates the day before work.

Say " good morning Hal"

Uh oh. I just got my clock icon today. I think I will wait to install the update until I can deal with any issue that may arise.

Keep us posted. I hope this is just a fluke!


This might be a good time to test the hypothesis that a gorgeous car sitting unlocked in a major urban center is usually left untouched, ostensibly due to the belief that the car likely belongs to an individual capable of shortening the lifespan of a thief considerably and with extreme prejudice.

What would they hotwire? And besides, it's trackable! They WILL get busted...


This sounds just like what mine does when one of the doors is ajar. Any chance that the car thinks one of the doors isn't completely closed?


Your trunk is slightly ajar. The screen will not show it as open. Tesla is aware of this issue.

Got my update yesterday. Not having this (or any) issue. Slightly disappointed that the only new thing according to release notes is timer charging. Though glad for you folks that can take advantage of it. I was hoping the anti-gravity module would finally be enabled so I could get up and out of traffic and away from all the Teslarazzi trying to take pics of me while they're driving.

From another thread, sounds like they finally fixed the range calculation in cool weather. ie. it now shows a more realistic estimated range based on the motor and battery heating up due to being driven rather than the incorrect assumption that the battery pack would stay at ambient temperature.

Don't think its associated with 4.3. I upgraded to 4.2 early last week (and 4.3 today) and the problem with the locking happened after 4.2. My answer (for now) is to turn off the "auto present door handles" in the settings. Either have to push on the handle or double press the fob to get in. But at least it locks properly.

@bigez1 - That could well be it. The trunk requires a bit of force to close properly, particularly if you've adjusted the stoppers because of the buffeting problem. I've noticed a couple times it doesn't tell me it's ajar, but it is...

Reminds me of what my high school English teacher used to say to us. When is a door not a door? When it's a jar! ;)

My will be downloading new v4.3 tonight. SOOO glad to have the timer for charging! I forget sometimes to plug in after 10pm and sometimes I'm sleeping by then!

@Geek EV

That exact same thing happened to me. The doors wouldn't lock no mattered what I tried. Naturally, I checked the display for open doors, etc. and nothing..... I also tried using the Android app - it would initially indicate the doors were locked and then immediately show they were unlocked. Then I remembered opening the trunk earlier - low and behold it wasn't completely shut. Problem solved. I emailed Tesla and was told (via email) a fix was forthcoming.

We have 4.3. Door no longer auto locks after walking away. We can leave the fob in the house and go to the car had have the handle present itself by touching it. However, we were able to lock the car using the fob, go inside the house to put the fob away, come back out to the car w/o the fob, and the door would not unlock.

@Hills - Try rebooting as they suggested for @TikiMan and possibly toggling the walk-away setting off and back on. Maybe the variable got reset to off or something.

@TikiMan - You might try toggling the various lock-settings off and back on as well.

I am not very worried about my small problem.

BTW I have had numerous occurance of intrument panel display going blank. Sometimes the left side, sometimes the right side, sometimes both sides. The worst was 2 days ago when it happened twice.

I learned to reboot the instrument panel only by pressing the space above both scroll wheel for about 15 seconds. Yes, Ownership Exp said 10 seconds, not long enough.

Update... Took my P85 to my local service center last night, and they ran a bunch of diagnostics, etc. Finally, they had Fremont's software engineers looking into my codes, and found some security code errors. After they found these errors, it was just a few mins before they fixed them.

My service specialist and the Fremont engineers weren't sure how this happened, however, I am starting to speculate that when I download updates from my garage, I am getting a VERY weak 3G signal, and that might have caused my MS to only partially get the entire update download. The next time when v4.4 comes out, I am going to make sure I move my car to a different location with a strong signal.

Otherwise, when I got home my new Lloyds floor mats had arrived, and an hour later my parcel-shelf was delivered.

BTW... While I was waiting for my car, I noticed there were what looked like almost fifty new MS's waiting to be prepped for delivery!!!! Go Tesla!

***Note: Off-Topic***

Can you give us some input on the Lloyds floor mats? Feel free to start another thread or e-mail me directly at

• Why did you choose Llyods?
• What floor mat companies did you evaluate?
• What Lloyds carpet material did you choose?
• What retailer did you buy them from?
• Your overall impressions of the product.


Here's a lot more info on front/rear floor mats, colors, etc.

Just had my "Christine" moment with her. Anxiously awaiting 4.3, VIN 1842. Went down to garage this morning and opened driver door and let her warm up. Back 10 minutes later to see if 4.3 was available ...nope. Bummer, no timed charging yet.

Closed her up. Went upstairs...10 minutes later my wife says, "our garage door just opened".
Huh? Sure enough it did.

Apparently NKYTA was unhappy not being driven at all yesterday. My bad. ;-)

She just opened the garage door by herself -again-!

Down to garage; actually sat in her and started her. No 4.3, played the radio a bit, opened and closed the garage door with Homelink; got out, pushed the fob button to close handles; back upstairs.

10 minutes later the garage door opens. WTF?

Down to garage again, wondering if the garage door electronics are faulty. All looks good, functions as normal.

Hmm...hit the lock function on the door so remotes won't work - let's see her get around that!

Clearly time to go for a drive...

That is what I get for anthropomorphizing the car. When locked it opened again - has to be the damn garage door.

Sorry this is so off-post, but to finish the story...

Wow, you could't script this if you tried.

Turns out my wife's remote door opener was in her jacket pocket - in the washing machine!

Still laughing :-)


Without starting a new thread, here are the answers on the mats...

-Lloyd's appear to have an excellent reputation over all others.
-I bought the 'Ultimat Custom' in black front and rear (matching my carpet) $200.00 + tax
-Got them via (very fast deliver using UPS ground)
They are VERY plush mats, and made of really great quality! (far better than the ones that came with my car). They fit perfectly.

Tikiman, you may want to edit the title of the thread to V4.3 bug resolved. Just sayin'

MandL - You had me LOL! I too have almost been the unfortunate victim numerous times to the Teslarazzi! I can't believe some people actually think its okay to drive and take pictures- right next to you!

Or behind you!! I am definetely using the term Teslarazzi from now on.

lo and behold: someone trying to escape from your trunk? Make sure the occupants are really dead before you load them in there.

All this time I was thinking that the car was intelligent and was trying to tell you that it wanted to be taken out for a ride. Bummer.